阅读背景:

阿里云 Ubuntu14.04 升级 python3.4 到 python 3.5/6

来源:互联网 

买的阿里云服务器给的系统是Ubuntu14.04,里面装的Python3版本是Python3.4,本来也没什么,但是这个版本的Python安装flask和django各种报错,所以只好升级Python.

以前我在虚拟机上运行Ubuntu的时候升级过Python,后果很不好,开关机老是报错,所以,在原系统上直接暴力升级是很不理智的.而且Ubuntu14.04的软件源对应的Python最新版本就是3.4的,温和的方式已经不行了.

那么就没有办法了吗?

有的,很简单,将阿里云的服务器系统更换成16.04就好了.

资源地址: https://help.aliyun.com/document_detail/50134.html?spm=a2c4g.11186623.2.8.3b6b47a0fJq04E#concept-n4k-x3j-ydb

简单说一下就是进入控制台,关闭实例,选择实例,选择更多,选择磁盘和镜像,选择更新系统盘,然后在界面里选择要更换的系统就好了.

实例重启之后,默认Python版本就是3.5了,安装flask和django不会报错了.


分享到: