阅读背景:

aws lambda使用.net core 2.0

来源:互联网 

I am trying to leverage the .net core 2.0 for AWS lambda and could not find any documentation for its support for same.

我正在尝试利用.net核心2.0 for AWS lambda,并且找不到任何支持它的文档。

Has anyone tried lambda targetting .net core 2.0 or is it supported?

有没有人尝试过lambda target .net core 2.0或者是否支持?

2 个解决方案

#1


6  

From the blog post Updates for .NET Core Lambda Libraries (8 May 2017):

来自博客文章更新.NET Core Lambda Libraries(2017年5月8日):

Lambda supports .NET Core 1.0. If you add a dependency to your .NET Core project that requires .NET Core 1.1, the .NET Core publishing tooling used by Amazon.Lambda.Tools will run without errors. However, when you run the function you’ll get errors because of the incompatibility. In version 1.5.0 of Amazon.Lambda.Tools we added validation on top of the .NET Core publishing tool to ensure that none of the dependencies for the project require a later runtime than Lambda supports.

Lambda支持.NET Core 1.0。如果向需要.NET Core 1.1的.NET Core项目添加依赖项,则Amazon.Lambda.Tools使用的.NET Core发布工具将正常运行。但是,当您运行该函数时,由于不兼容性,您将收到错误。在Amazon.Lambda.Tools的1.5.0版本中,我们在.NET Core发布工具之上添加了验证,以确保项目的所有依赖项都不需要比Lambda支持的更高的运行时。

#2


3  

AWS Lambda now supports .net core 2.0:

AWS Lambda现在支持.net核心2.0:

https://aws.amazon.com/about-aws/whats-new/2018/01/aws-lambda-supports-c-sharp-dot-net-core-2-0/

https://aws.amazon.com/about-aws/whats-new/2018/01/aws-lambda-supports-c-sharp-dot-net-core-2-0/


分享到: