阅读背景:

不支持Project facet Cloud Foundry独立应用程序1.0版本

来源:互联网 

I am trying to start a spring starter project. After creating the project, I am suppose to go into the pom.xml file and give the packaging tag of type 'war'.

我正在尝试启动一个spring starter项目。创建项目后,我应该进入pom。xml文件,并给出“war”类型的打包标记。

<groupId>org.test</groupId> artifactId>demo</artifactId> <version>0.0.1-SNAPSHOT</version> <packaging>war</packaging>

< groupId > org。演示测试< / groupId > artifactId > < / artifactId > <版本> 0.0.1-SNAPSHOT < /版本> <包装> < /包装>战争

I then update the Maven project and then proceed to add the project to the tomcat server. However, I am getting this error:

然后更新Maven项目,然后继续将项目添加到tomcat服务器。然而,我得到了这个错误:

Project facet Cloud Foundry Standalone Application version 1.0 is not supported.

项目facet Cloud Foundry独立应用程序版本1.0不受支持。

What can be the problem? Also note that I have done this before and it didn't work. I tried it again and it was able to work. Now that I am on a different system, it doesn't work again. I am also following the Introduction to Spring MVC 4 tutorial

有什么问题吗?还要注意的是,我以前也做过这个,但是没有用。我又试了一次,终于成功了。现在我在一个不同的系统上,它不能再工作了。我还在学习Spring MVC 4教程的介绍

2 个解决方案

#1


1  

Had the exact same issue in Spring STS.

在春季STS中也有同样的问题。

To resolve: a. in STS right click project root (project name)-> click properties -> Search for "Project Facets", and uncheck "Cloud Foundry standalone Application" and press OK

解决方法:a.在STS中右键点击项目根(项目名称)->点击属性->搜索“项目面”,取消选中“云代工独立应用程序”并按OK

b. right click project root (project name) again -> Maven -> Update Project (shortcut Alt+F5)

b.右键点击项目根(项目名称)-> Maven ->更新项目(快捷Alt+F5)

c. you will then be able to add the project to the server

然后,您将能够将项目添加到服务器

#2


-1  

Remove the Clound Foundary Standalone Application version 1.0 facet from the project via project -> properties -> project facets.

通过project -> properties -> project facet,从项目中删除Clound Foundary独立应用程序版本1.0 facet。


分享到: